Sign in to follow this  
Followers 0
superslug2000

Textures are missing in nifscope and game, and all the tutorials and forums haven't helped

1 post in this topic

In nifskope my textures are missing, giving me a spear made of white diffuse stuff. I also got the model in game and still have a texture-less spear.

I am using blender 2.79 with "Blender Nif Plugin 2.6.0 Pre Alpha 0 Dev 4 - Nightly build" and "Nifscope 2.0.0 pre-Alpha 6". the latest version of everything.

in nifscope->options-> settings-> resources my path is set as "C:/Program Files (x86)/Bethesda Softworks/Morrowind/Data Files". I have the texture for the blade set as "textures\antikneetextures\spear_knee_slay_blade.dds", and the texture for the shaft is set as "textures\antikneetextures\spear_knee_slay_shaft.dds".

I have the nif stored in "C:\Program Files (x86)\Bethesda Softworks\Morrowind\Data Files\Meshes\AntiKnee" because nifskope apparently expects the textures an meshes to be under the same data folder.

I checked if the uv maps survived the export from blender by right clicking on the object, ->Texture -> Edit UV, and the uv map looks like what a had in blender. I also triangulated the mesh in blender.

 in blender's object panel, BS Num UV set is 1, the consistency is set to ct mutable and the object flag is 4, and in blender's scene panel nif version is set to 0 (because this value is defunct and works fine if set 0), user version is set to 0, and user version 2 is set to 0 the like all Morrowind weapons seem to be.

I think part of the problem is that blender merges the two materials, even thought they are on two different objects (pointy end and shaft)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0